Z-axis movement

What is there that protects a user from trying to move the z-axis 100mm if that is the movement preset set for x/y and the z-axis button is clicked? I have not done this but paranoid about possibly doing it since I had to disable my soft limits to get my machine calibrated and working. 

If there is no protection in the software currently, could that be a feature improvement? It would be nice to limit the z-axis to options that are within the travel distance, say no more than 10 or 20 mm maximum. separate out the travel presets so there are x/y presets and z-axis presets.


1 person has this question
  • This is actually what the soft limits are supposed to do but the do not work correctly as of the last software update. I believe they are working on it.

    1 person likes this
  • I have the same issue, but I can't even move 5mm without"ALARM:2 (Soft Limit)" shutting me down!  My Z-axis is totally dead.  I have tried the reset and Unlock buttons without any sucess. 


    1 person likes this
  • Don, it sounds like you may need to turn off your soft limits to get moving again. The machine is in a position that it thinks is not safe to move. The soft limits are a bit cautious in my opinion, so it can happen fairly easily. You can access your soft limits in your settings on the left side. Once you get your z-axis back sort of in the middle, you should be able to turn the soft limits on again. Just remember, while the soft limits are off, you can technically attempt to move your z-axis 100mm and it will try to do this. Be ready to pause the movement or turn off your motors to prevent any damage. Double check the movement distance before moving your z-axis and you should be fine.

  • GHOST IN THE MACHINE

    Well, I got the Z motor to operate, but now it wont stop! Where is the magic button to make the Z motor stop running??  I have tried:

    1) Pushing the RESET button (no effect)

    2) Unplugging the motor (that  works!), then powering down the system and closing the software(windows).  

    However, when I power up the system, reopen the software and plug the motor back in, it is still running!!

    How do I kill this thing?

  • Don,


    Unplug the USB cord. The Arduino gets its power from USB. The power supply only powers the motor shield.


  • Hi , Need help we have completed calibration as per described but when we try to cut. the router bit is not cutting it stays  0.19 inch above the board we are using essel to create the art, can we get help to resolve this issue

  • It sounds like your Z-axis probably needs to be calibrated as well.


    Check out this great video by Casey Connolly that details the process: https://youtu.be/JQ_dZVcOvEE


    And also the section on the Z-axis calibration tab in our calibration guide: https://cdn.shopify.com/s/files/1/0555/9903/8630/files/M2_Calibration_Guide.pdf?v=1637614067



  • hello all


    maybe you could help me with this issue. I'm a new owner and more importantly new operator. I've been through the calibration process and it amazingly went well. i created a simple circle through easel, downloaded the gcode and uploaded it into makerverse. all loads correctly, I turn on my router, hit start and the router starts cutting. The issue is that the toolpath to the circle gets cut then when the router gets to where the circle would be it lifts out of the cut and the program continues to make the passes to create the circle. 


    long story short what do I need to do to get the router to cut the pattern and not the path to the pattern. zero seems good on the x axis. it touches the work piece when I tell it to go to machine zero on the z axis.


  • when you set your z axis zero, do you then back your router up before starting your cut? I set my zero, then move my router up to 5mm above zero before I start cutting a project. Are you leaving it at zero when your start cutting?
  • when i start the program the z axis is 3 to 5 mm off of the surface. it then starts cutting immediately when i hit start. it is only cutting the path to the pattern or picture. the circle in my case. as soon as the bit is where the router should plunge to start cutting the circle it lifts out of the cut and continues to run the pattern until its finished, its almost like the sequence is reversed. to me the router should travel to the pattern start then cut the pattern. its starting the cut as soon as i hit start then lifting when it gets to where it should be starting the cut. 

  • One thing you can check is go to the website https://ncviewer.com/ . You can upload your g-code file (.nc file) and then let it run virtually to see if the code is telling the machine to cut the movement path instead of the actual cut path. If it is doing exactly what your M2 is doing, then the file is setup incorrectly. 

    If it is not matching your M2, then I think you might have your z-axis reversed or perhaps there is a setting that was missed. Check that your z-axis cable is properly seated at both the Arduino and the motor connectors. If it is slightly askew, it can cause strange behavior. After that, if you still have issues, you should submit a ticket to MakerMade to have them help you diagnose the problem. Let us know in the forums your outcome so we have the collective knowledge for the future.

  • I really appreciate all the help. Joel from support service figured it out. Somehow the setting for the step direction and z axis resolution were not correct he had me change them and behold I cut my first circle. Thanks again all
Login or Signup to post a comment