Makerverse 1.1.3 unable to connect to community OpenWorkShop to get CNC profiles

Hi. I'm a software/network engineer, so I'm pretty savvy with networking. So, when I say that the Makerverse 1.1.3 software (standalone and web version) won't connect to the OpenWorkShop community when creating a new workspace, you can rest assured I've disabled my firewalls, avoided any VPNs, etc.

What happens is this:

  1. I open the Makerverse 1.1.3 app
  2. I verify it shows that I'm logged in (can see "Logged in as a.........y" when I click on the person icon in the upper right
  3. Click on "Connect to a New Machine" in the "New Workspace" area
  4. It flashes very quickly to a screen that mentions being unable to connect to the OpenWorkShop cummunity, but it changes so quickly I don't have a chance to capture a screenshot of it. By using the developer tools I can see it sent the following request:
    Request URL: https://openwork.shop/api/machines?_=1641139218088
    Request Method: OPTIONS
    Status Code: 204
    Remote Address: 18.221.80.76:443
    Referrer Policy: no-referrer-when-downgrade
  5. I know the 204 status code means "No Content success status response code" and indicates that a request has succeeded, but that the client doesn't need to navigate away from its current page. Ok fine.
  6. The next network request is to omy local machine:
    Request URL: http://127.0.0.1:55473/7e4b2aed/d6c7e9d3e5adb7a5261c5ad9f7d3caaa.woff
    Request Method: GET
    Status Code: 200 OK
    Remote Address: 127.0.0.1:55473
  7. Ok, so that request was also successful.
  8. The next request is back out to openwork.shop as follows:
    Request URL: https://openwork.shop/api/machines?_=1641139218088
    Request Method: GET
    Status Code: 200
    Remote Address: 18.221.80.76:443
  9. That request seemed successful, and yet I get a screen that looks like the attached image:

    image

  10. This screen has no M2 listed, nor the Due, nor the Mega... which according to the instructions should all be showing up...

WHAT DO I DO?

Thanks for the help in advance!

  • There is currently an issue with Makerverse loading the default catalog. 

    Typically, you can select the M2 from a list of machines.

    You will need to input your machine controller settings and your workspace dimensions manually.


    Below are the steps to Connect to a New Machine and Create a New Workspace.    



    1) Connect

    image


    2) Create a New Machine

    image

    3) Machine Controller Selection

    image

    4) Port Connection

    image

    5) Workspace Size and Name

    image


    6) Create Workspace

    image

Login or Signup to post a comment